google code-beautifer

星期二, 4月 10, 2007

在64bit 2007(.0 跟.1)MDV上跑32 bit 套件

v1.0 星期二, 四月 10, 2007
v2.0 星期四, 六月 21, 2007 更新在2007.1 上的結果

這個問題很少人提到,大多是卡在商業軟體的搭配。在這裡先整理一下我目前的解答。其實是不用去用到 32 bit chroot

java:


2007.1
現在已經有nono-free 的java RPM 可以下載,包括64b位元套件。但似乎只有 64bit OOo 抓得到64bit jre 。32bit OOo 還是得裝 32bit jre 所以可以裝powerpack 上的 jdk2-1.4.2_13-2mdv2007.1.i586.rpm或是去sun 直接下載

2007.0: blackdown 有 amd64 版本 (firefox 2測試webct 沒問題)

安裝blackdown 版64bit java
wget ftp://mirrors.ibiblio.org/pub/mirrors/blackdown/JDK-1.4.2/amd64/03/
cp j2sdk-1.4.2-03-linux-amd64.bin /usr/local
cd /usr/local
chmod 700 j2sdk-1.4.2-03-linux-amd64.bin

把下面加入 /etc/prifle
PATH=$PATH:/usr/local/j2sdk1.4.2/bin
ln -s /usr/local/j2sdk1.4.2/jre/plugin/amd64/mozilla/libjavaplugin_oji.so ~/.mozilla/plugins/libjavaplugin_oji.so

要注意
The J2SDK installer automatically adds Java Web Start entries to
$(HOME)/.mime.types and $(HOME)/.mailcap. For multi-user
installations you have to copy these entries to /etc/.mime.type

openoffice:


2007上有 64 bit 版本,可以抓到blackdown 版本java沒問題
但是 bibus 需要用 32bit OOo 來跑,java 的設定參見java 一節

flash player 9:


gcin需要更新版 ,見gcin
詳細中文環境設定見安裝 flash 9 player 的正確解答

skype


1.3.0.53 RPM:未滿足 libqt-mt.so.3 但可至http://www.skype.com/download/skype/linux/
下載Static binary tar.bz2 with Qt compiled in (14.0 MB) tar 版本安裝,會需要 libstdc++.so.5

nspluginwarpper


在 firefox 上的32 bit plugin可用nspluginwarpper 來解決
http://gwenole.beauchesne.info/en/projects/nspluginwrapper
nspluginwrapper 0.9.91.3支援
* Acrobat Reader (5.0.9, 7.0.1)
* DejaVu Libre (3.5.14)
* Flash Player (7.0, 9.0)
* Linux JPEG 2000 (0.0.2)
* Mplayerplug-in (2.80, 3.25)
* Real Player (10.0.5)

acrobat reader


acroread-7.0.9-1mdv2007.1.i586.rpm 需要一些系統的32位元套件,如libgnomespeech7-0.4.10-1mdv2007.1.i586.rpm 在64b位元機器上可能會有衝突,會需要大量更換成32位元套件,2007.0跟2007.1可以用下列順序安裝mdv2006的32位元套件,就不用動到64位元系統套件

acroread-7.0.1-3mdk
acroread-l10n-zh_TW-7.0.1-3mdk
acroread-plugins-extwin-7.0.1-3mdk
acroread-nppdf-7.0.1-3mdk
acroread-plugins-ecmascript-7.0.1-3mdk
acroread-plugins-forms-7.0.1-3mdk
acroread-plugins-makeaccessible-7.0.1-3mdk
acroread-plugins-pddom-7.0.1-3mdk
acroread-plugins-saveasrtf-7.0.1-3mdk
acroread-plugins-searchfind-7.0.1-3mdk
acroread-plugins-accessibility-7.0.1-3mdk
acroread-plugins-spelling-7.0.1-3mdk
acroread-plugins-weblink-7.0.1-3mdk
acroread-plugins-internetaccess-7.0.1-3mdk
acroread-plugins-comments-7.0.1-3mdk
acroread-plugins-checkers-7.0.1-3mdk
acroread-plugins-digitalsignature-7.0.1-3mdk
acroread-plugins-legalpdf-7.0.1-3mdk
acroread-plugins-sendmail-7.0.1-3mdk
acroread-plugins-soap-7.0.1-3mdk
acroread-plugins-ppklite-7.0.1-3mdk

Real player


有一些RMVB 跟串流的檔案我還是無法用 mplayer+win32codec 播放,所以還是
去裝 Real player。Real.com 上可以下載,或者powerpack 上的
RealPlayer-10.0.8.805-5mdv2007.1.i586.rpm
RealPlayer-rpnp-10.0.8.805-5mdv2007.1.i586.rpm
看起來也是差不多

gcin


在2007.1 上更新版本後就沒問題了,可以跟emacs,twinview雙螢幕跟aiglx 下
的compiz 搭工作正常。

2007.0:
更新版32bit gcin RPM未滿足libqt-mt.so.3見
http://cle.linux.org.tw/trac/discussion/1/250
(我有一封回函討論到細節但離gcin比較遠的的被刪了,不知道是不是cle 最近硬碟不穩的緣故)
編譯gcin-1.3.4.pre4(Mandriva 2007.0 64bit)錯誤
http://cle.linux.org.tw/trac/discussion/1/257

cd /usr/lib
ln -s /usr/lib64/libXtst.so.6 libXtst.so
cd /usr/local/gcin-1.3.4.pre4/
make clean
./configure
make
make install
這樣gedit, gnome-terminal 都沒問題,但發現emacs 22 沒法叫出gcin ,
我發了一個討論 "(多重)gcin 安裝設定"
http://cle.linux.org.tw/trac/discussion/1/260
後來發現好像不是xgl 出了問題,這個問題麻煩好大,要過一陣子再來追

4 則留言:

匿名 提到...

http://cle.linux.org.tw/trac/discussion/1/260/988#988

應該沒有被砍的吧?

shelandy 提到...

不是這一篇,不過我都已經把64bit 跑32 bit 套件的方案做出來,討論"不重要的討論"不是重點,我倒希望cle 的硬碟趕快修好,好讓討論正常下去倒是真的,不然這篇跟下面要寫的gcin 是沒辦法在短時間內生出來的。cle 的硬碟三天兩頭出問題讓人頭痛。

匿名 提到...

gcin 和 xgl 這算是 known issue

能試的就是 XIM 和 old gtk im
(gcin 預設啟用 new gtk im)

shelandy 提到...

我也注意到好像是xgl 而不是twinview跟 gcin 的問題

我實在不知該如何說明這件事:
所以在gcin 同好會上留了這一篇
gcin 1.3.3, emacs 22 &xgl (站務問題?)

google 找到最近的是同好會上的 108 "1.3.2的new_gtk_im好像會和xgl有衝突"swyear 2 weeks 01/15/07 18:42:33 4 可是進去 forum 2 卻找不到 108的文章。不知是不是CLE 硬碟掛掉造成的問題?